Binding Name

All the posts and topics that contain only an error report will be moved here after the error is corrected. This is to ensure that when users view a question in ETS Viewer, the "Discuss" button will not indicate the presence of a discussion that adds no value to the question.

Moderators: Site Manager, fjwalraven

Post Reply
jaderss
Posts: 5
Joined: Fri Oct 03, 2014 2:58 pm
Contact:

Binding Name

Post by jaderss » Sun Oct 26, 2014 6:19 pm

I think that the question has an error. The port name derives from portType, end the binding derives from serviceName. Therefore, the correct wsdl is:

<wsdl:portType name="LogService">
<wsdl:operation name="log">
<wsdl:input message="tns:log" name="log"></wsdl:input>
<wsdl:output message="tns:logResponse" name="logResponse"></wsdl:output>
</wsdl:operation>
</wsdl:portType>
<wsdl:binding name="LogWebServiceSoapBinding" type="tns:LogService">
<soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
<wsdl:operation name="log">
<soap:operation soapAction="" style="document"/>
<wsdl:input name="log">
<soap:body use="literal"/>
</wsdl:input>
<wsdl:output name="logResponse">
<soap:body use="literal"/>
</wsdl:output>
</wsdl:operation>
</wsdl:binding>
<wsdl:service name="LogWebService">
<wsdl:port binding="tns:LogWebServiceSoapBinding" name="LogServicePort">
<soap:address location="http://localhost:8080/ocejwsd/LogWebService"/>
</wsdl:port>
</wsdl:service>

fjwalraven
Posts: 429
Joined: Tue Jul 24, 2012 2:43 am
Contact:

Re: Binding Name

Post by fjwalraven » Mon Oct 27, 2014 12:29 am

Could you please tell me the question number?

Regards,
Frits

jaderss
Posts: 5
Joined: Fri Oct 03, 2014 2:58 pm
Contact:

Re: Binding Name

Post by jaderss » Mon Oct 27, 2014 1:00 pm

Yes,

id=enthuware.ocejws.v6.2.27

It's the second question in test 5.

Sorry for the post in the wrong place.

fjwalraven
Posts: 429
Joined: Tue Jul 24, 2012 2:43 am
Contact:

Re: Binding Name

Post by fjwalraven » Mon Oct 27, 2014 3:25 pm

No problem, I already thought that it might be that one.

You are right the binding name is not correct. It should be based on the port name: LogServicePortBinding. Although not relevant to the question it should be correct.

I have corrected all options likewise. Thanks again for your feedback!

Regards,
Frits

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests