About Question enthuware.ocejws.v6.2.151 :

All the posts and topics that contain only an error report will be moved here after the error is corrected. This is to ensure that when users view a question in ETS Viewer, the "Discuss" button will not indicate the presence of a discussion that adds no value to the question.

Moderators: Site Manager, fjwalraven

Post Reply
fabiolino
Posts: 25
Joined: Wed Jun 24, 2015 7:26 am
Contact:

About Question enthuware.ocejws.v6.2.151 :

Post by fabiolino » Mon Jun 29, 2015 2:30 am

what you say is correct and I would add sun-jaxws.xml with enable-mtom="true"

fabiolino
Posts: 25
Joined: Wed Jun 24, 2015 7:26 am
Contact:

Re: About Question enthuware.ocejws.v6.2.151 :

Post by fabiolino » Mon Jun 29, 2015 2:40 am

Sorry, i just read again the question and i see "client side".

fjwalraven
Posts: 429
Joined: Tue Jul 24, 2012 2:43 am
Contact:

Re: About Question enthuware.ocejws.v6.2.151 :

Post by fjwalraven » Mon Jun 29, 2015 2:54 am

Hi Fabiolino,

Did you update the Question Bank recently? Question 2.151 has been changed in the last major update.

Regards,
Frits

fabiolino
Posts: 25
Joined: Wed Jun 24, 2015 7:26 am
Contact:

Re: About Question enthuware.ocejws.v6.2.151 :

Post by fabiolino » Wed Jul 08, 2015 8:43 am

...
Content-Type: //3 application/xop+xml; charset=utf-8;type=//4 "application/soap+xml"

//4 should be type="text/xml" ?

fjwalraven
Posts: 429
Joined: Tue Jul 24, 2012 2:43 am
Contact:

Re: About Question enthuware.ocejws.v6.2.151 :

Post by fjwalraven » Wed Jul 08, 2015 2:40 pm

//4 should be type="text/xml" ?
No, that is true for SwA. For MTOM it is:

Code: Select all

type="application/soap+xml"
Regards,
Frits

fabiolino
Posts: 25
Joined: Wed Jun 24, 2015 7:26 am
Contact:

Re: About Question enthuware.ocejws.v6.2.151 :

Post by fabiolino » Thu Jul 09, 2015 2:06 am

hi,
see 6.2.137

...
and response 2:
...
Content-Type: application/xop+xml;charset=utf-8;type="text/xml"

fjwalraven
Posts: 429
Joined: Tue Jul 24, 2012 2:43 am
Contact:

Re: About Question enthuware.ocejws.v6.2.151 :

Post by fjwalraven » Thu Jul 09, 2015 3:17 pm

Good catch! You are correct, this is different in question 2.137.

I have looked into it and it has to do with the SOAP version of the specifications.
SOAP v1.1 MTOM -> uses type="text/xml"
SOAP v1.2 MTOM -> uses type="application/soap+xml"
(check https://jax-ws.java.net/2.2.1/docs/mtom-swaref.html)

This version of the WSD exam only tests knowledge of SOAP v1.1.

I will change this question (2.151)

Thank you for your feedback!
Frits

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests